What’s Vulnerable › Vulnerabilities
CVE-2025-12630: Upload.am File Hosting VPN < 1.0.1 - Contributor+ Arbitrary Option Disclosure
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-02 · updated 2026-09-25
Description
The Upload.am WordPress plugin before 1.0.1 is vulnerable to arbitrary option disclosure due to a missing capability check on its AJAX request handler, allowing users such as contributor to view site options.
Affected products
- Upload.am: before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: Upload.am 1.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12630 or the next vulnerability affects your stack