What’s Vulnerable › Vulnerabilities
CVE-2025-12635: IBM WebSphere Application Server and WebSphere Application Server Liberty Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-08 · updated 2026-10-07
- Weakness: CWE-79
Description
IBM WebSphere Application Server 8.5, 9.0 and IBM WebSphere Application Server Liberty 17.0.0.3 through 25.0.0.12 are affected by cross-site scripting due to improper validation of user-supplied input. An attacker could exploit this vulnerability by using a specially crafted URL to redirect the user to a malicious site.
Affected products
- IBM WebSphere Application Server: from 8.5 before 8.5.5.29; from 9.0 before 9.0.5.27; from 17.0.0.3 before 26.0.0.1 — fixed in 26.0.0.1, 8.5.5.29, 9.0.5.27
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 26.0.0.1, 8.5.5.29, 9.0.5.27. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12635 or the next vulnerability affects your stack