What’s Vulnerable › Vulnerabilities
CVE-2025-12653: Authentication Bypass by Spoofing in GitLab
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-26 · updated 2026-10-18
- Weakness: CWE-290
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.3 before 18.4.5, 18.5 before 18.5.3, and 18.6 before 18.6.1 that under specific conditions could have allowed an unauthenticated user to join arbitrary organizations by changing headers on some requests.
Affected products
- GitLab: from 18.3.0 before 18.4.5; from 18.5.0 before 18.5.3; 18.6.0 — fixed in 18.4.5, 18.5.3
How to fix
Upgrade to a fixed version: GitLab 18.4.5, 18.5.3. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2025/11/26/patch-release-gitlab-18-6-1-released/
- https://gitlab.com/gitlab-org/gitlab/-/issues/579372
- https://hackerone.com/reports/3370245
Get alerted when CVE-2025-12653 or the next vulnerability affects your stack