What’s Vulnerable › Vulnerabilities
CVE-2025-12657: Malformed KMIP response may result in access violation
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-03 · updated 2026-10-18
- Weakness: CWE-754
Description
The KMIP response parser built into mongo binaries is overly tolerant of certain malformed packets, and may parse them into invalid objects. Later reads of this object can result in read access violations.
Affected products
- MongoDB: from 6.0.0 before 7.0.22; from 8.0.0 before 8.0.10 — fixed in 7.0.22, 8.0.10
How to fix
Upgrade to a fixed version: MongoDB 7.0.22, 8.0.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12657 or the next vulnerability affects your stack