What’s Vulnerable › Vulnerabilities
CVE-2025-12669: Improper Control of Generation of Code ('Code Injection') in GitLab
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-14 · updated 2026-10-14
- Weakness: CWE-94
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.11 before 18.9.7, 18.10 before 18.10.6, and 18.11 before 18.11.3 that could have allowed an authenticated user to inject HTML and JavaScript into email notifications sent to other users due to improper input sanitization.
Affected products
- GitLab: from 15.11.0 before 18.9.7; from 18.10.0 before 18.10.6; from 18.11.0 before 18.11.3 — fixed in 18.10.6, 18.11.3, 18.9.7
How to fix
Upgrade to a fixed version: GitLab 18.10.6, 18.11.3, 18.9.7. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2026/05/13/patch-release-gitlab-18-11-3-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/579385
- https://hackerone.com/reports/3368096
Get alerted when CVE-2025-12669 or the next vulnerability affects your stack