What’s Vulnerable › Vulnerabilities
CVE-2025-12684: URL Shortify < 1.11.3 - Reflected XSS
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-15 · updated 2026-10-07
Description
The URL Shortify WordPress plugin before 1.11.3 does not sanitize and escape a parameter before outputting it back in the page, leading to a reflected cross site scripting, which could be used against high-privilege users such as admins.
Affected products
- URL Shortify: before 1.11.3 — fixed in 1.11.3
How to fix
Upgrade to a fixed version: URL Shortify 1.11.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12684 or the next vulnerability affects your stack