What’s Vulnerable › Vulnerabilities
CVE-2025-12686
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-27 · updated 2026-10-07
- Weakness: CWE-120
Description
Buffer copy without checking size of input ('Classic Buffer Overflow') vulnerability in AdminCenter in Synology BeeStation OS before 1.3.2-65648 allows remote attackers to execute arbitrary code via unspecified vectors.
Affected products
- Synology BeeStation OS: from 1.0 before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: Synology BeeStation OS 1.3.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12686 or the next vulnerability affects your stack