What’s Vulnerable › Vulnerabilities
CVE-2025-12690: Local Privilege Escalation in NGFW Engine
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-250
Description
Execution with unnecessary privileges in Forcepoint NGFW Engine allows local privilege escalation.This issue affects NGFW Engine through 6.10.19, through 7.3.0, through 7.2.4, through 7.1.10.
Affected products
- Forcepoint Next Generation Firewall: before 6.10.20; from 7.1.0 before 7.1.11; from 7.2.0 before 7.2.5; 7.3.0 — fixed in 6.10.20, 7.1.11, 7.2.5
How to fix
Upgrade to a fixed version: Forcepoint Next Generation Firewall 6.10.20, 7.1.11, 7.2.5. Check the vendor advisory for mitigations.
References
- https://support.forcepoint.com/s/article/Security-Advisory-Local-Privilege-Escalation-in-NGFW-Engine
Get alerted when CVE-2025-12690 or the next vulnerability affects your stack