What’s Vulnerable › Vulnerabilities

CVE-2025-12697: Improper Encoding or Escaping of Output in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.5 before 18.7.6, 18.8 before 18.8.6, and 18.9 before 18.9.2 that could have allowed an authenticated user with maintainer-role permissions to reveal Datadog API credentials under certain conditions.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.7.6, 18.8.6, 18.9.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-12697 or the next vulnerability affects your stack