What’s Vulnerable › Vulnerabilities

CVE-2025-12734: Improper Encoding or Escaping of Output in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.6 before 18.4.6, 18.5 before 18.5.4, and 18.6 before 18.6.2 that could have allowed an authenticated user to, under certain conditions, render content in dialogs to other users by injecting malicious HTML content into merge request titles.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.4.6, 18.5.4, 18.6.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-12734 or the next vulnerability affects your stack