What’s Vulnerable › Vulnerabilities
CVE-2025-12738: Enumeration of restricted property value
- Severity: low (CVSS 1.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-22 · updated 2026-06-17
- Weakness: CWE-200
Description
Neo4j Enterprise edition versions prior to 2025.11.2 and 5.26.17 are vulnerable to a potential information disclosure by an attacker who has some legitimate access to the database. The vulnerability allows attacker without read access to a property to infer information about its value by trying to enumerate all possible values through observing error messages of SET property. We recommend upgrading to 2025.11.2 or 5.26.17 and above, where the issues is fixed.
Affected products
- neo4j Enterprise Edition: before 2025.11.2; before 5.26.17 — fixed in 2025.11.2, 5.26.17
How to fix
Upgrade to a fixed version: neo4j Enterprise Edition 2025.11.2, 5.26.17. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12738 or the next vulnerability affects your stack