What’s Vulnerable › Vulnerabilities
CVE-2025-12739: Cross-Site Scripting (XSS) in Looker's Extension Loader leading to Admin Account Compromise
- Severity: high (CVSS 7.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-24 · updated 2026-10-08
- Weakness: CWE-79
Description
An attacker with viewer permissions in Looker could craft a malicious URL that, when opened by a Looker admin, would execute an attacker-supplied script. Exploitation required at least one Looker extension installed on the instance. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : * 24.18.201+ * 25.0.79+ * 25.6.66+ * 25.12.7+ * 25.16.0+ * 25.18.0+ * 25.20.0+
Affected products
- Google Cloud Looker: before 24.18.201; before 25.0.79; before 25.6.66; before 25.12.7; before 25.16.0; before 25.18.0 — fixed in 24.18.201, 25.0.79, 25.12.7, 25.16.0, 25.18.0, 25.20.0
How to fix
Upgrade to a fixed version: Google Cloud Looker 24.18.201, 25.0.79, 25.12.7, 25.16.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12739 or the next vulnerability affects your stack