What’s Vulnerable › Vulnerabilities
CVE-2025-12740: Remote Command Execution in Looker via IBM DB2 JDBC drive
- Severity: high (CVSS 7.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-24 · updated 2026-10-08
- Weakness: CWE-20
Description
A Looker user with a Developer role could create a database connection using IBM DB2 driver and, by manipulating LookML, cause Looker to execute a malicious command, due to inadequate filtering of the driver's parameters. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : * 25.0.93+ * 25.6.84+ * 25.12.42+ * 25.14.50+ * 25.16.44+
Affected products
- Google Cloud Looker: before 25.0.93; before 25.6.84; before 25.12.42; before 25.14.50; before 25.16.44 — fixed in 25.0.93, 25.12.42, 25.14.50, 25.16.44, 25.6.84
How to fix
Upgrade to a fixed version: Google Cloud Looker 25.0.93, 25.12.42, 25.14.50, 25.16.44. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12740 or the next vulnerability affects your stack