What’s Vulnerable › Vulnerabilities
CVE-2025-12741: Arbitrary File Write in Denodo dialect of Looker allows Remote Code Execution
- Severity: high (CVSS 7.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-24 · updated 2026-10-08
- Weakness: CWE-20
Description
A Looker user with Developer role could create a database connection using Denodo driver and, by manipulating LookML, cause Looker to execute a malicious command. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : * 24.12.108+ * 24.18.200+ * 25.0.78+ * 25.6.65+ * 25.8.47+ * 25.12.10+ * 25.14+
Affected products
- Google Cloud Looker: before 24.12.108; before 24.18.200; before 25.0.78; before 25.6.65; before 25.8.47; before 25.12.10 — fixed in 24.12.108, 24.18.200, 25.0.78, 25.12.10, 25.14, 25.6.65
How to fix
Upgrade to a fixed version: Google Cloud Looker 24.12.108, 24.18.200, 25.0.78, 25.12.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12741 or the next vulnerability affects your stack