What’s Vulnerable › Vulnerabilities

CVE-2025-12756: Insecure Direct Object Reference in Mattermost Boards Plugin Enables Unauthorised Comment Deletion

Description

Mattermost versions 11.0.x <= 11.0.2, 10.12.x <= 10.12.1, 10.11.x <= 10.11.4, 10.5.x <= 10.5.12 fail to validate user permissions when deleting comments in Boards, which allows an authenticated user with the editor role to delete comments created by other users.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.5, 10.12.2, 10.5.13, 11.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-12756 or the next vulnerability affects your stack