What’s Vulnerable › Vulnerabilities
CVE-2025-12758
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-27 · updated 2026-10-19
- Weakness: CWE-792
Description
Versions of the package validator before 13.15.22 are vulnerable to Incomplete Filtering of One or More Instances of Special Elements in the isLength() function that does not take into account Unicode variation selectors (\uFE0F, \uFE0E) appearing in a sequence which lead to improper string length calculation. This can lead to an application using isLength for input validation accepting strings significantly longer than intended, resulting in issues like data truncation in databases, buffer overflows in other system components, or denial-of-service.
Affected products
- validatorjs/validator.js: before 13.15.22 — fixed in 13.15.22
How to fix
Upgrade to a fixed version: validatorjs/validator.js 13.15.22. Check the vendor advisory for mitigations.
References
- https://gist.github.com/koral--/ad31208b25b9e3d1e2e35f1d4d72572e
- https://github.com/validatorjs/validator.js/pull/2616
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-14152011
- https://security.snyk.io/vuln/SNYK-JS-VALIDATOR-13653476
- http://seclists.org/fulldisclosure/2026/Jan/27
- https://security.snyk.io/vuln/SNYK-JS-VALIDATOR-13653476
Get alerted when CVE-2025-12758 or the next vulnerability affects your stack