What’s Vulnerable › Vulnerabilities
CVE-2025-12762: Remote Code Execution vulnerability when restoring PLAIN-format SQL dumps in server mode (pgAdmin 4)
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-13 · updated 2026-10-18
- Weakness: CWE-94
Description
pgAdmin versions up to 9.9 are affected by a Remote Code Execution (RCE) vulnerability that occurs when running in server mode and performing restores from PLAIN-format dump files. This issue allows attackers to inject and execute arbitrary commands on the server hosting pgAdmin, posing a critical risk to the integrity and security of the database management system and underlying data.
Affected products
- pgadmin.org pgAdmin 4: before 9.10 — fixed in 9.10
How to fix
Upgrade to a fixed version: pgadmin.org pgAdmin 4 9.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12762 or the next vulnerability affects your stack