What’s Vulnerable › Vulnerabilities
CVE-2025-12763: Command injection vulnerability allowing arbitrary command execution on Windows
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-13 · updated 2026-10-07
- Weakness: CWE-78
Description
pgAdmin 4 versions up to 9.9 are affected by a command injection vulnerability on Windows systems. This issue is caused by the use of shell=True during backup and restore operations, enabling attackers to execute arbitrary system commands by providing specially crafted file path input.
Affected products
- pgadmin.org pgAdmin 4: before 9.10 — fixed in 9.10
How to fix
Upgrade to a fixed version: pgadmin.org pgAdmin 4 9.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12763 or the next vulnerability affects your stack