What’s Vulnerable › Vulnerabilities
CVE-2025-12764: pgAdmin 4: LDAP injection vulnerability in LDAP authentication flow.
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-13 · updated 2026-10-07
- Weakness: CWE-90
Description
pgAdmin <= 9.9 is affected by an LDAP injection vulnerability in the LDAP authentication flow that allows an attacker to inject special LDAP characters in the username, causing the DC/LDAP server and the client to process an unusual amount of data DOS.
Affected products
- pgadmin.org pgAdmin 4: before 9.10 — fixed in 9.10
How to fix
Upgrade to a fixed version: pgadmin.org pgAdmin 4 9.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12764 or the next vulnerability affects your stack