What’s Vulnerable › Vulnerabilities
CVE-2025-12765: pgAdmin 4: LDAP authentication flow vulnerable to TLS certificate verification bypass.
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-13 · updated 2026-10-07
- Weakness: CWE-295
Description
pgAdmin <= 9.9 is affected by a vulnerability in the LDAP authentication mechanism allows bypassing TLS certificate verification.
Affected products
- pgadmin.org pgAdmin 4: before 9.10 — fixed in 9.10
How to fix
Upgrade to a fixed version: pgadmin.org pgAdmin 4 9.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12765 or the next vulnerability affects your stack