What’s Vulnerable › Vulnerabilities
CVE-2025-12771: IBM Concert Software Improper Restriction of Operations within the Bounds of a Memory Buffer.
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-26 · updated 2026-10-07
- Weakness: CWE-119
Description
IBM Concert 1.0.0 through 2.1.0 is vulnerable to a stack-based buffer overflow, caused by improper bounds checking. A local user could overflow the buffer and execute arbitrary code on the system.
Affected products
- IBM Concert: from 1.0.0 before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: IBM Concert 2.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-12771 or the next vulnerability affects your stack