What’s Vulnerable › Vulnerabilities
CVE-2025-1278: Insufficient Granularity of Access Control in GitLab
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-09 · updated 2026-06-17
- Weakness: CWE-1220
Description
An issue has been discovered in GitLab CE/EE affecting all versions from 12.0 before 17.9.8, 17.10 before 17.10.6, and 17.11 before 17.11.2. Under certain conditions users could bypass IP access restrictions and view sensitive information.
Affected products
- GitLab: from 12.0.0 before 17.9.8; from 17.10.0 before 17.10.6; from 17.11.0 before 17.11.2 — fixed in 17.10.6, 17.11.2, 17.9.8
How to fix
Upgrade to a fixed version: GitLab 17.10.6, 17.11.2, 17.9.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-1278 or the next vulnerability affects your stack