What’s Vulnerable › Vulnerabilities
CVE-2025-1281: BM Content Builder < 3.17.1 - Authenticated (Subscriber+) Arbitrary File Deletion
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-22 · updated 2026-10-14
- Weakness: CWE-22
Description
The BM Content Builder plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the ux_cb_remove_layout_ajax() and ux_cb_tools_export_ajax() functions in all versions up to, and excluding, 3.17.1. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).
Affected products
- SeaTheme BM Content Builder: before 3.17.1 — fixed in 3.17.1
How to fix
Upgrade to a fixed version: SeaTheme BM Content Builder 3.17.1. Check the vendor advisory for mitigations.
References
- https://themeforest.net/item/art-simple-clean-wordpress-theme-for-creatives/20170299
- https://www.wordfence.com/threat-intel/vulnerabilities/id/61084da5-fa8d-4fa9-a6a6-6155e9e25fbc?source=cve
Get alerted when CVE-2025-1281 or the next vulnerability affects your stack