What’s Vulnerable › Vulnerabilities
CVE-2025-12816: CVE-2025-12816
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-25 · updated 2026-10-18
- Weakness: CWE-436
Description
An interpretation-conflict (CWE-436) vulnerability in node-forge versions 1.3.1 and earlier enables unauthenticated attackers to craft ASN.1 structures to desynchronize schema validations, yielding a semantic divergence that may bypass downstream cryptographic verifications and security decisions.
Affected products
- digitalbazaar forge: through 1.3.1
- Npm Node-Forge: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: Npm Node-Forge 1.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/digitalbazaar/forge
- https://github.com/digitalbazaar/forge/pull/1124
- https://github.com/digitalbazaar/forge/security/advisories/GHSA-5gfm-wpxj-wjgq
- https://kb.cert.org/vuls/id/521113
- https://www.npmjs.com/package/node-forge
- https://www.kb.cert.org/vuls/id/521113
Get alerted when CVE-2025-12816 or the next vulnerability affects your stack