What’s Vulnerable › Vulnerabilities
CVE-2025-12819: Untrusted search path in auth_query connection in PgBouncer
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-03 · updated 2026-10-18
- Weakness: CWE-426
Description
Untrusted search path in auth_query connection handler in PgBouncer before 1.25.1 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.
Affected products
- PgBouncer: before 1.25.1 — fixed in 1.25.1
How to fix
Upgrade to a fixed version: PgBouncer 1.25.1. Check the vendor advisory for mitigations.
References
- https://www.pgbouncer.org/changelog.html#pgbouncer-125x
- https://lists.debian.org/debian-lts-announce/2025/12/msg00033.html
Get alerted when CVE-2025-12819 or the next vulnerability affects your stack