What’s Vulnerable › Vulnerabilities
CVE-2025-1282: Car Dealer Automotive WordPress Theme – Responsive <= 1.6.3 - Authenticated (Subscriber+) Arbitrary File Deletion and Read
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-06-17
- Weakness: CWE-22
Description
The Car Dealer Automotive WordPress Theme – Responsive theme for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the delete_post_photo() and add_car() functions in all versions up to, and including, 1.6.3. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php). The add_car() function may also make it possible to read arbitrary files.
Affected products
- ThemeMakers Car Dealer Automotive WordPress Theme – Responsive: before 1.6.4 — fixed in 1.6.4
How to fix
Upgrade to a fixed version: ThemeMakers Car Dealer Automotive WordPress Theme – Responsive 1.6.4. Check the vendor advisory for mitigations.
References
- https://themeforest.net/item/car-dealer-automotive-wordpress-theme-responsive/8574708?s_rank=7
- https://www.wordfence.com/threat-intel/vulnerabilities/id/edf4b588-8b67-425a-b0e1-d4382cb88dd1?source=cve
Get alerted when CVE-2025-1282 or the next vulnerability affects your stack