What’s Vulnerable › Vulnerabilities
CVE-2025-12907
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-08 · updated 2026-10-07
- Weakness: CWE-20
Description
Insufficient validation of untrusted input in Devtools in Google Chrome prior to 140.0.7339.80 allowed a remote attacker to execute arbitrary code via user action in Devtools. (Chromium security severity: Low)
Affected products
- Google Chrome: before 140.0.7339.80 — fixed in 140.0.7339.80
How to fix
Upgrade to a fixed version: Google Chrome 140.0.7339.80. Check the vendor advisory for mitigations.
References
- https://chromereleases.googleblog.com/2025/09/stable-channel-update-for-desktop.html
- https://issues.chromium.org/issues/427367145
Get alerted when CVE-2025-12907 or the next vulnerability affects your stack