What’s Vulnerable › Vulnerabilities
CVE-2025-1293: HashiCorp Hermes Improperly Validates AWS ALB JWTs, which May Lead to Authentication Bypass
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-20 · updated 2026-06-17
- Weakness: CWE-1390
Description
Hermes versions up to 0.4.0 improperly validated the JWT provided when using the AWS ALB authentication mode, potentially allowing for authentication bypass. This vulnerability, CVE-2025-1293, was fixed in Hermes 0.5.0.
Affected products
- HashiCorp Hermes: before 0.5.0 — fixed in 0.5.0
How to fix
Upgrade to a fixed version: HashiCorp Hermes 0.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-1293 or the next vulnerability affects your stack