What’s Vulnerable › Vulnerabilities
CVE-2025-12942: Improper input validation in NETGEAR R6260 and R6850
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-11 · updated 2026-10-18
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in NETGEAR R6260 and NETGEAR R6850 allows unauthenticated attackers connected to LAN with ability to perform MiTM attacks and control over DNS Server to perform command execution.This issue affects R6260: through 1.1.0.86; R6850: through 1.1.0.86.
Affected products
- NETGEAR R6260: before 1.1.0.86 — fixed in 1.1.0.86
- NETGEAR R6850 Firmware: before 1.1.0.86 — fixed in 1.1.0.86
How to fix
Upgrade to a fixed version: NETGEAR R6260 1.1.0.86; NETGEAR R6850 Firmware 1.1.0.86. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000070355/NETGEAR-Security-Advisories-November-2025
- https://www.netgear.com/support/product/r6260
- https://www.netgear.com/support/product/r6850
Get alerted when CVE-2025-12942 or the next vulnerability affects your stack