What’s Vulnerable › Vulnerabilities
CVE-2025-12943: Improper certificate validation in firmware update logic in NETGEAR RAX30 and RAXE300
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-11 · updated 2026-10-18
- Weakness: CWE-295
Description
Improper certificate validation in firmware update logic in NETGEAR RAX30 (Nighthawk AX5 5-Stream AX2400 WiFi 6 Router) and RAXE300 (Nighthawk AXE7800 Tri-Band WiFi 6E Router) allows attackers with the ability to intercept and tamper traffic destined to the device to execute arbitrary commands on the device. Devices with automatic updates enabled may already have this patch applied. If not, please check the firmware version and update to the latest. Fixed in: RAX30 firmware 1.0.14.108 or later. RAXE300 firmware 1.0.9.82 or later
Affected products
- NETGEAR RAX30: before 1.0.14.108 — fixed in 1.0.14.108
- NETGEAR Raxe300 Firmware: before 1.0.9.82 — fixed in 1.0.9.82
How to fix
Upgrade to a fixed version: NETGEAR RAX30 1.0.14.108; NETGEAR Raxe300 Firmware 1.0.9.82. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000070355/NETGEAR-Security-Advisories-November-2025
- https://www.netgear.com/support/product/rax30
- https://www.netgear.com/support/product/raxe300
Get alerted when CVE-2025-12943 or the next vulnerability affects your stack