What’s Vulnerable › Vulnerabilities
CVE-2025-12944: Improper input validation in NETGEAR DGN2200v4
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-11 · updated 2026-10-18
- Weakness: CWE-20
Description
Improper input validation in NETGEAR DGN2200v4 (N300 Wireless ADSL2+ Modem Router) allows attackers with direct network access to the device to potentially execute code on the device. Please check the firmware version and update to the latest. Fixed in: DGN2200v4 firmware 1.0.0.132 or later
Affected products
- NETGEAR Dgn2200 Firmware: before 1.0.0.132 — fixed in 1.0.0.132
How to fix
Upgrade to a fixed version: NETGEAR Dgn2200 Firmware 1.0.0.132. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000070355/NETGEAR-Security-Advisories-November-2025
- https://www.netgear.com/support/product/dgn2200v4
Get alerted when CVE-2025-12944 or the next vulnerability affects your stack