What’s Vulnerable › Vulnerabilities
CVE-2025-12946: Improper input validation in NETGEAR Nighthawk routers
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-09 · updated 2026-10-07
- Weakness: CWE-20
Description
A vulnerability in the speedtest feature of affected NETGEAR Nighthawk routers, caused by improper input validation, can allow attackers on the router's WAN side, using attacker-in-the-middle techniques (MiTM) to manipulate DNS responses and execute commands when speedtests are run. This issue affects RS700: through 1.0.7.82; RAX54Sv2 : before V1.1.6.36; RAX41v2: before V1.1.6.36; RAX50: before V1.2.14.114; RAXE500: before V1.2.14.114; RAX41: before V1.0.17.142; RAX43: before V1.0.17.142; RAX35v2: before V1.0.17.142; RAXE450: before V1.2.14.114; RAX43v2: before V1.1.6.36; RAX42: before V1.0.17.142; RAX45: before V1.0.17.142; RAX50v2: before V1.1.6.36; MR90: before V1.0.2.46; MS90: before V1.0.2.46; RAX42v2: before V1.1.6.36; RAX49S: before V1.1.6.36.
Affected products
- NETGEAR Mr90 Firmware: before 1.0.2.46 — fixed in 1.0.2.46
- NETGEAR Ms90 Firmware: before 1.0.2.46 — fixed in 1.0.2.46
- NETGEAR Rax35V2 Firmware: before 1.0.17.142 — fixed in 1.0.17.142
- NETGEAR Rax41 Firmware: before 1.0.17.142 — fixed in 1.0.17.142
- NETGEAR Rax41V2 Firmware: before 1.1.6.36 — fixed in 1.1.6.36
- NETGEAR Rax42 Firmware: before 1.0.17.142 — fixed in 1.0.17.142
- NETGEAR Rax42V2 Firmware: before 1.1.6.36 — fixed in 1.1.6.36
- Netgear RAX43: before 1.0.17.142 — fixed in 1.0.17.142
- NETGEAR Rax43V2 Firmware: before 1.1.6.36 — fixed in 1.1.6.36
- NETGEAR Rax45 Firmware: before 1.0.17.142 — fixed in 1.0.17.142
- NETGEAR Rax45V2 Firmware: before 1.1.6.36 — fixed in 1.1.6.36
- NETGEAR Rax49S Firmware: before 1.1.6.36 — fixed in 1.1.6.36
- NETGEAR Rax50 Firmware: before 1.2.14.114 — fixed in 1.2.14.114
- NETGEAR Rax50V2 Firmware: before 1.1.6.36 — fixed in 1.1.6.36
- NETGEAR Rax54Sv2 Firmware: before 1.1.6.36 — fixed in 1.1.6.36
- NETGEAR Raxe450 Firmware: before 1.0.17.142 — fixed in 1.0.17.142
- NETGEAR Raxe500 Firmware: before 1.2.14.114 — fixed in 1.2.14.114
- NETGEAR Rs700 Firmware: before 1.0.9.6 — fixed in 1.0.9.6
How to fix
Upgrade to a fixed version: NETGEAR Mr90 Firmware 1.0.2.46; NETGEAR Ms90 Firmware 1.0.2.46; NETGEAR Rax35V2 Firmware 1.0.17.142; NETGEAR Rax41 Firmware 1.0.17.142; NETGEAR Rax41V2 Firmware 1.1.6.36; NETGEAR Rax42 Firmware 1.0.17.142; NETGEAR Rax42V2 Firmware 1.1.6.36; Netgear RAX43 1.0.17.142; NETGEAR Rax43V2 Firmware 1.1.6.36; NETGEAR Rax45 Firmware 1.0.17.142; NETGEAR Rax45V2 Firmware 1.1.6.36; NETGEAR Rax49S Firmware 1.1.6.36. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000070416/December-2025-NETGEAR-Security-Advisory
- https://www.netgear.com/support/product/RAX50
- https://www.netgear.com/support/product/mr90
- https://www.netgear.com/support/product/ms90
- https://www.netgear.com/support/product/rax35v2
- https://www.netgear.com/support/product/rax41
- https://www.netgear.com/support/product/rax41v2
- https://www.netgear.com/support/product/rax42
- https://www.netgear.com/support/product/rax42v2
- https://www.netgear.com/support/product/rax43
- https://www.netgear.com/support/product/rax43v2
- https://www.netgear.com/support/product/rax45
Get alerted when CVE-2025-12946 or the next vulnerability affects your stack