What’s Vulnerable › Vulnerabilities

CVE-2025-1299: Missing Authorization in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 15.4 before 18.0.5, all versions starting from 18.1 before 18.1.3, all versions starting from 18.2 before 18.2.1 that, under circumstances, could have allowed an unauthorized user to read deployment job logs by sending a crafted request.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.0.5, 18.1.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-1299 or the next vulnerability affects your stack