What’s Vulnerable › Vulnerabilities
CVE-2025-13033: Nodemailer: nodemailer: email to an unintended domain can occur due to interpretation conflict
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-14 · updated 2026-10-18
- Weakness: CWE-1286
Description
A vulnerability was identified in the email parsing library due to improper handling of specially formatted recipient email addresses. An attacker can exploit this flaw by crafting a recipient address that embeds an external address within quotes. This causes the application to misdirect the email to the attacker's external address instead of the intended internal recipient. This could lead to a significant data leak of sensitive information and allow an attacker to bypass security filters and access controls.
Affected products
- nodemailer: before 7.0.7 — fixed in 7.0.7
- Red Hat Advanced Cluster Management for Kubernetes 2: all versions
- Red Hat Ceph Storage 8.1: all versions — fixed in 1777566546
- Red Hat Developer Hub 1.9: all versions — fixed in 1772573159
How to fix
Upgrade to a fixed version: nodemailer 7.0.7; Red Hat Ceph Storage 8.1 1777566546; Red Hat Developer Hub 1.9 1772573159. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:15979
- https://access.redhat.com/errata/RHSA-2026:3751
- https://access.redhat.com/security/cve/CVE-2025-13033
- https://bugzilla.redhat.com/show_bug.cgi?id=2402179
- https://github.com/nodemailer/nodemailer
- https://github.com/nodemailer/nodemailer/commit/1150d99fba77280df2cfb1885c43df23109a8626
- https://github.com/nodemailer/nodemailer/security/advisories/GHSA-mm7p-fcc7-pg87
Get alerted when CVE-2025-13033 or the next vulnerability affects your stack