What’s Vulnerable › Vulnerabilities
CVE-2025-1304: NewsBlogger <= 0.2.5.1 - Authenticated (Subscriber+) Arbitrary File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-06-17
- Weakness: CWE-862
Description
The NewsBlogger theme for WordPress is vulnerable to arbitrary file uploads due to a missing capability check on the newsblogger_install_and_activate_plugin() function in all versions up to, and including, 0.2.5.1. This makes it possible for authenticated attackers, with subscriber-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.
Affected products
- spicethemes NewsBlogger: before 0.2.5.2 — fixed in 0.2.5.2
How to fix
Upgrade to a fixed version: spicethemes NewsBlogger 0.2.5.2. Check the vendor advisory for mitigations.
References
- https://themes.trac.wordpress.org/browser/newsblogger/0.2.5.5/functions.php?annotate=blame&rev=269615#file2
- https://themes.trac.wordpress.org/browser/newsblogger/0.2/functions.php#L440
- https://themes.trac.wordpress.org/browser/newsblogger/0.2/functions.php#L461
- https://themes.trac.wordpress.org/browser/newsblogger/0.2/functions.php#L470
- https://www.wordfence.com/threat-intel/vulnerabilities/id/85cea6b5-d57b-495e-a504-a0c1ba691637?source=cve
Get alerted when CVE-2025-1304 or the next vulnerability affects your stack