What’s Vulnerable › Vulnerabilities
CVE-2025-1306: Newscrunch <= 1.8.4 - Cross-Site Request Forgery to Arbitrary File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-04 · updated 2026-06-17
- Weakness: CWE-352
Description
The Newscrunch theme for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.8.4. This is due to missing or incorrect nonce validation on the newscrunch_install_and_activate_plugin() function. This makes it possible for unauthenticated attackers to upload arbitrary files via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- spicethemes Newscrunch: before 1.8.4.1 — fixed in 1.8.4.1
How to fix
Upgrade to a fixed version: spicethemes Newscrunch 1.8.4.1. Check the vendor advisory for mitigations.
References
- https://themes.trac.wordpress.org/browser/newscrunch/1.8.3/functions.php#L486
- https://themes.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=261789%40newscrunch&new=261789%40newscrunch&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1c507681-61e9-4bf0-8fe5-e2f401a7a8be?source=cve
Get alerted when CVE-2025-1306 or the next vulnerability affects your stack