What’s Vulnerable › Vulnerabilities

CVE-2025-13078: Improper Validation of Specified Quantity in Input in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 16.10 before 18.8.7, 18.9 before 18.9.3, and 18.10 before 18.10.1 that could have allowed an authenticated user to cause a denial of service due to excessive resource consumption when processing certain webhook configuration inputs.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.8.7, 18.9.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-13078 or the next vulnerability affects your stack