What’s Vulnerable › Vulnerabilities
CVE-2025-13086
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-03 · updated 2026-09-25
- Weakness: CWE-940
Description
Improper validation of source IP addresses in OpenVPN version 2.6.0 through 2.6.15 and 2.7_alpha1 through 2.7_rc1 allows an attacker to open a session from a different IP address which did not initiate the connection resulting in a denial of service for the originating client
Affected products
- OpenVPN: from 2.6.0 before 2.6.16; 2.7-alpha1, 2.7-alpha2, 2.7-alpha3, 2.7-beta1, 2.7-beta2, 2.7-beta3 (+1) — fixed in 2.6.16
How to fix
Upgrade to a fixed version: OpenVPN 2.6.16. Check the vendor advisory for mitigations.
References
- https://community.openvpn.net/Security%20Announcements/CVE-2025-13086
- https://www.mail-archive.com/openvpn-announce@lists.sourceforge.net/msg00151.html
- https://www.mail-archive.com/openvpn-announce@lists.sourceforge.net/msg00152.html
Get alerted when CVE-2025-13086 or the next vulnerability affects your stack