What’s Vulnerable › Vulnerabilities
CVE-2025-13087: Command Injection in Opto22 Groov REST API
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-20 · updated 2026-10-18
- Weakness: CWE-78
Description
A vulnerability exists in the Opto22 Groov Manage REST API on GRV-EPIC and groov RIO Products that allows remote code execution with root privileges. When a POST request is executed against the vulnerable endpoint, the application reads certain header details and unsafely uses these values to build commands, allowing an attacker with administrative privileges to inject arbitrary commands that execute as root.
Affected products
- Opto22 groov RIO GRV-R7-I1VAPM-3: before 4.0.3 — fixed in 4.0.3
- Opto22 groov RIO GRV-R7-MM1001-10: before 4.0.3 — fixed in 4.0.3
- Opto22 groov RIO GRV-R7-MM2001-10: before 4.0.3 — fixed in 4.0.3
- Opto22 GRV-EPIC-PR1: before 4.0.3 — fixed in 4.0.3
- Opto22 GRV-EPIC-PR2: before 4.0.3 — fixed in 4.0.3
How to fix
Upgrade to a fixed version: Opto22 groov RIO GRV-R7-I1VAPM-3 4.0.3; Opto22 groov RIO GRV-R7-MM1001-10 4.0.3; Opto22 groov RIO GRV-R7-MM2001-10 4.0.3; Opto22 GRV-EPIC-PR1 4.0.3; Opto22 GRV-EPIC-PR2 4.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/cisagov/CSAF/blob/develop/csaf_files/OT/white/2025/icsa-25-324-03.json
- https://www.cisa.gov/news-events/ics-advisories/icsa-25-324-03
- https://www.opto22.com/support/resources-tools/knowledgebase/kb91326
Get alerted when CVE-2025-13087 or the next vulnerability affects your stack