What’s Vulnerable › Vulnerabilities
CVE-2025-1320: teachPress <= 9.0.9 - Cross-Site Request Forgery to Import Delete
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-25 · updated 2026-06-17
- Weakness: CWE-352
Description
The teachPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 9.0.9. This is due to missing or incorrect nonce validation on the import.php page. This makes it possible for unauthenticated attackers to delete imports via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- winkm89 teachPress: before 9.0.10 — fixed in 9.0.10
How to fix
Upgrade to a fixed version: winkm89 teachPress 9.0.10. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3259464%40teachpress&new=3259464%40teachpress&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/teachpress/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b677ad8b-4f01-4147-bcf6-ae769046be48?source=cve
Get alerted when CVE-2025-1320 or the next vulnerability affects your stack