What’s Vulnerable › Vulnerabilities
CVE-2025-1324: WP-Recall – Registration, Profile, Commerce & More <= 16.26.10 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP-Recall – Registration, Profile, Commerce & More plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'public-form' shortcode in all versions up to, and including, 16.26.10 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- wppost WP-Recall – Registration, Profile, Commerce & More: before 16.26.12 — fixed in 16.26.12
How to fix
Upgrade to a fixed version: wppost WP-Recall – Registration, Profile, Commerce & More 16.26.12. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3250094/wp-recall/trunk/add-on/publicpost/shortcodes.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3e0be093-d61a-4634-ba9b-91dd7328e8cd?source=cve
Get alerted when CVE-2025-1324 or the next vulnerability affects your stack