What’s Vulnerable › Vulnerabilities
CVE-2025-1327: Homey - Booking and Rentals WordPress Theme <= 2.4.4 - Insecure Direct Object Reference to Authenticated (Subscriber+) Arbitrary User Deletion
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-02 · updated 2026-06-17
- Weakness: CWE-639
Description
The Homey theme for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 2.4.4 via the 'homey_delete_user_account' action due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete other user's accounts.
Affected products
- Fave Themes Homey: before 2.4.5 — fixed in 2.4.5
How to fix
Upgrade to a fixed version: Fave Themes Homey 2.4.5. Check the vendor advisory for mitigations.
References
- https://themeforest.net/item/homey-booking-wordpress-theme/23338013
- https://www.wordfence.com/threat-intel/vulnerabilities/id/38aa649c-e9d3-458b-b567-e2e751aaca00?source=cve
Get alerted when CVE-2025-1327 or the next vulnerability affects your stack