What’s Vulnerable › Vulnerabilities
CVE-2025-13307: Ocean Modal Window < 2.3.3 - Editor+ Remote Code Execution via Modal Conditions
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-19 · updated 2026-06-17
Description
The Ocean Modal Window WordPress plugin before 2.3.3 is vulnerable to Remote Code Execution via the modal display logic. These modals can be displayed under user-controlled conditions that Editors and Administrators can set (edit_pages capability). The conditions are then executed as part of an eval statement executed on every site page. This leads to remote code execution.
Affected products
- Ocean Modal Window: before 2.3.3 — fixed in 2.3.3
How to fix
Upgrade to a fixed version: Ocean Modal Window 2.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-13307 or the next vulnerability affects your stack