What’s Vulnerable › Vulnerabilities
CVE-2025-13394: Cross-Site Request Forgery via Ajax Processor Endpoints in Multiple WSO2 Products Enables Unauthorized Actions
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-09-29
- Weakness: CWE-352
Description
The Ajax processor within the Carbon console fails to adequately protect state-changing operations from Cross-Site Request Forgery (CSRF) attacks. Specifically, it utilizes the HTTP GET method for these operations, and while the SameSite=Lax cookie attribute is employed for mitigation, this mechanism is bypassed as it permits cookies to be sent with cross-origin top-level navigation requests, including GET requests. This allows an attacker to trick an authenticated user's browser into unknowingly executing unintended actions. An attacker can exploit this vulnerability to perform unauthorized state-altering requests on behalf of authenticated users. This could lead to consequences such as data modification, account changes, or other actions that could result in data compromise or loss of user control over their account. However, this attack is only feasible if the Carbon console and related services are exposed to the public internet, which is not recommended according to WSO2's security guidelines.
Affected products
- WSO2 Api Control Plane: from 4.5.0 before 4.5.0.39; from 4.6.0 before 4.6.0.3 — fixed in 4.5.0.39, 4.6.0.3
- WSO2 API Manager: from 3.1.0 before 3.1.0.352; from 3.2.0 before 3.2.0.456; from 3.2.1 before 3.2.1.75; from 4.0.0 before 4.0.0.376; from 4.1.0 before 4.1.0.239; from 4.2.0 before 4.2.0.179 — fixed in 3.1.0.352, 3.2.0.456, 3.2.1.75, 4.0.0.376, 4.1.0.239, 4.2.0.179
- WSO2 Enterprise Integrator: from 6.6.0 before 6.6.0.227 — fixed in 6.6.0.227
- WSO2 Identity Server: from 5.10.0 before 5.10.0.381; from 5.11.0 before 5.11.0.428; from 6.0.0 before 6.0.0.255; from 6.1.0 before 6.1.0.256; from 7.0.0 before 7.0.0.133; from 7.1.0 before 7.1.0.41 — fixed in 5.10.0.381, 5.11.0.428, 6.0.0.255, 6.1.0.256, 7.0.0.133, 7.1.0.41
- WSO2 Identity Server As Key Manager: from 5.10.0 before 5.10.0.372 — fixed in 5.10.0.372
- WSO2 Open Banking Am: from 2.0.0 before 2.0.0.401 — fixed in 2.0.0.401
- WSO2 Open Banking Iam: from 2.0.0 before 2.0.0.421 — fixed in 2.0.0.421
- WSO2 Traffic Manager: from 4.5.0 before 4.5.0.37; from 4.6.0 before 4.6.0.3 — fixed in 4.5.0.37, 4.6.0.3
- WSO2 Universal Gateway: from 4.5.0 before 4.5.0.37; from 4.6.0 before 4.6.0.3 — fixed in 4.5.0.37, 4.6.0.3
How to fix
Upgrade to a fixed version: WSO2 Api Control Plane 4.5.0.39, 4.6.0.3; WSO2 API Manager 3.1.0.352, 3.2.0.456, 3.2.1.75, 4.0.0.376; WSO2 Enterprise Integrator 6.6.0.227; WSO2 Identity Server 5.10.0.381, 5.11.0.428, 6.0.0.255, 6.1.0.256; WSO2 Identity Server As Key Manager 5.10.0.372; WSO2 Open Banking Am 2.0.0.401; WSO2 Open Banking Iam 2.0.0.421; WSO2 Traffic Manager 4.5.0.37, 4.6.0.3; WSO2 Universal Gateway 4.5.0.37, 4.6.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-13394 or the next vulnerability affects your stack