What’s Vulnerable › Vulnerabilities
CVE-2025-13407: GravityForms < 2.9.23.1 - Unauthenticated Arbitrary File Upload
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-24 · updated 2026-10-19
Description
The Gravity Forms WordPress plugin before 2.9.23.1 does not properly prevent users from uploading dangerous files through its chunked upload functionality, allowing attackers to upload PHP files to affected sites and achieve Remote Code Execution, granted they can discover or enumerate the upload path.
Affected products
- Gravity Forms: before 2.9.23.1 — fixed in 2.9.23.1
How to fix
Upgrade to a fixed version: Gravity Forms 2.9.23.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-13407 or the next vulnerability affects your stack