What’s Vulnerable › Vulnerabilities
CVE-2025-13426: Improper Sandboxing in Google Apigee's JavaCallout Policy Allows for Remote Code Execution
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-05 · updated 2026-09-25
- Weakness: CWE-913
Description
A vulnerability exists in Google Apigee's JavaCallout policy https://docs.apigee.com/api-platform/reference/policies/java-callout-policy that allows for remote code execution. It is possible for a user to write a JavaCallout that injected a malicious object into the MessageContext to execute arbitrary Java code and system commands at runtime, leading to unauthorized access to data, lateral movement within the network, and access to backend systems. The Apigee hybrid versions below have all been updated to protect from this vulnerability: * Hybrid_1.11.2+ * Hybrid_1.12.4+ * Hybrid_1.13.3+ * Hybrid_1.14.1+ * OPDK_5202+ * OPDK_5300+
Affected products
- Google Cloud Apigee hybrid Javacallout policy: before Hybrid_1.11.2; before Hybrid_1.12.4; before Hybrid_1.13.3; before Hybrid_1.14.1; before OPDK_5202; before OPDK_5300 — fixed in Hybrid_1.11.2, Hybrid_1.12.4, Hybrid_1.13.3, Hybrid_1.14.1, OPDK_5202, OPDK_5300
How to fix
Upgrade to a fixed version: Google Cloud Apigee hybrid Javacallout policy Hybrid_1.11.2, Hybrid_1.12.4, Hybrid_1.13.3, Hybrid_1.14.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-13426 or the next vulnerability affects your stack