What’s Vulnerable › Vulnerabilities
CVE-2025-13428: RCE in SecOps SOAR server via user-provided Python packages
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-09 · updated 2026-10-07
- Weakness: CWE-20
Description
A vulnerability exists in the SecOps SOAR server. The custom integrations feature allowed an authenticated user with an "IDE role" to achieve Remote Code Execution (RCE) in the server. The flaw stemmed from weak validation of uploaded Python package code. An attacker could upload a package containing a malicious setup.py file, which would execute on the server during the installation process, leading to potential server compromise. No customer action is required. All customers have been automatically upgraded to the fixed version: 6.3.64 or higher.
Affected products
- Google Cloud SecOps SOAR: before 6.3.64 — fixed in 6.3.64
How to fix
Upgrade to a fixed version: Google Cloud SecOps SOAR 6.3.64. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-13428 or the next vulnerability affects your stack