What’s Vulnerable › Vulnerabilities

CVE-2025-13436: Allocation of Resources Without Limits or Throttling in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 13.7 before 18.8.7, 18.9 before 18.9.3, and 18.10 before 18.10.1 that could have allowed an authenticated user to cause a denial of service due to excessive resource consumption when handling certain CI-related inputs.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.8.7, 18.9.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-13436 or the next vulnerability affects your stack