What’s Vulnerable › Vulnerabilities
CVE-2025-13457: WooCommerce Square <= 5.1.1 - Unauthenticated Insecure Direct Object Reference to Sensitive Information Exposure in get_token_by_id
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-10 · updated 2026-06-17
- Weakness: CWE-639
Description
The WooCommerce Square plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 5.1.1 via the get_token_by_id function due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to expose arbitrary Square "ccof" (credit card on file) values and leverage this value to potentially make fraudulent charges on the target site.
Affected products
- WooCommerce Square: from 4.2.0 before 4.2.3; from 4.3.0 before 4.3.2; from 4.4.0 before 4.4.2; from 4.5.0 before 4.5.2; from 4.6.0 before 4.6.4; from 4.7.0 before 4.7.4 — fixed in 4.2.3, 4.3.2, 4.4.2, 4.5.2, 4.6.4, 4.7.4
How to fix
Upgrade to a fixed version: WooCommerce Square 4.2.3, 4.3.2, 4.4.2, 4.5.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3415850/woocommerce-square
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c7f4f726-7e53-4397-8d8b-7a574326adc6?source=cve
Get alerted when CVE-2025-13457 or the next vulnerability affects your stack