What’s Vulnerable › Vulnerabilities
CVE-2025-13465: Prototype Pollution Vulnerability in Lodash _.unset and _.omit functions
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-21 · updated 2026-10-15
- Weakness: CWE-1321
Description
The _.unset and _.omit functions in Lodash are vulnerable to prototype pollution. An attacker can pass crafted paths which cause Lodash to delete methods from global prototypes. The issue permits deletion of properties but does not allow overwriting their original behavior. The issue is patched from 4.17.23 to 4.18.0 depending on the package: lodash, lodash-es, and lodash-amd in 4.17.23, and the standalone lodash.unset and lodash.omit packages in 4.18.0.
Affected products
- lodash: from 4.0.0 before 4.17.23 — fixed in 4.17.23
- Npm Lodash: from 4.0.0 before 4.17.23 — fixed in 4.17.23
- Npm Lodash-Amd: from 4.0.0 before 4.17.23 — fixed in 4.17.23
- Npm Lodash-Es: from 4.0.0 before 4.17.23 — fixed in 4.17.23
- Npm Lodash.Unset: from 4.0.0 through 4.5.2
How to fix
Upgrade to a fixed version: lodash 4.17.23; Npm Lodash 4.17.23; Npm Lodash-Amd 4.17.23; Npm Lodash-Es 4.17.23. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/lodash/lodash/security/advisories/GHSA-xxjr-mmjv-4gpg
- https://access.redhat.com/errata/RHSA-2026:11414
- https://access.redhat.com/errata/RHSA-2026:13542
- https://access.redhat.com/errata/RHSA-2026:13548
- https://access.redhat.com/errata/RHSA-2026:13829
- https://access.redhat.com/errata/RHSA-2026:14774
- https://access.redhat.com/errata/RHSA-2026:14870
- https://access.redhat.com/errata/RHSA-2026:14871
- https://access.redhat.com/errata/RHSA-2026:15091
- https://access.redhat.com/errata/RHSA-2026:17469
- https://access.redhat.com/errata/RHSA-2026:1845
Get alerted when CVE-2025-13465 or the next vulnerability affects your stack